Windows 8.1 Raid Trim not working.

Discussion in 'Help and Support' started by SputNick7, Mar 7, 2014.

  1. SputNick7

    SputNick7 New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    First of Been reading for some time now. Never post or help the community as much as I should.

    Motherboard: Asus Z87-Delxue Bios 1602, Southbirdge rev C1

    Cpu: Intel 4770k Stepping 3 Revision C0

    Ram: Corsair CMD16GX3M2A1866C9


    Hard drives: Corsair CCSDF128GBGS-BK x4 Raid 0 Firmware 5.24 , CSSDF90GBGT x2 Firmware 5.05, CSSD-F120GBLS x 2 Firmware (have to get back not installed waiting on Vantec 8bay hot swap rack), WD1001FALS-00E8B0 x1, WD1002FAEX-00Z3A0 x2 Raid 1

    The rest is not helpful.

    So here is my problem.

    Install Windows 7 64bit home prem On the four 128 GS in raid 0 which was created in BIOS with 32kb Stripe. During the install I updated the latest Intel raid drivers (12.9.0.1001) via usb drive. Install goes well and quickly. Load up Windows 7 Install Chipset drivers Then RST and Intel ME. Do a trim check via Trimcheck 0.5 (which I found out about from your Website article TRIMcheck: Does Your SSD Really have TRIM Working? Thanks for it has helped me learn a lot) Also Used Hex Editor to double check it was working. (don’t know forum rules about where I got the info Will give credit where due if allowed). IT worked everything was fine. Which made me happy.

    Oh that install was done with old firmware 5.20

    Went to install Windows 8.1 64bit, Before I did that loaded up a copy of windows 7 with ACHI mode installed Did a Secure Wipe Throw Corsair SSD Toolbox, Reason I belive it write zeros to the whole drive. (I might be wrong. I have looked little but no luck on full info from your web page. Do you guys have one?) Loaded Up old windows install on a single Force GT. Other is being shipped back to corsair due to not showing up in bios. Which is why I order new drives for raid. Had the Raid build in Intel RST. Did some benchmarks was laughing at the speeds and seeing the limits of onboard raid. Went to check same method did in windows 7 not working in 8.1.

    So from there I booted back into Windows 7 ACHI mode updated firmware to latest 5.24 did another Secure Wipe. Loaded up My Windows 8.1 install with my Intel drive load in using Microsofts developers tools. To keep my os clean and secure as possible (Don’t like using Microsoft trusted methods for core install.) Started the Install. Rebuild raid in bios again. Loaded latest Intel raid drivers. Boot into windows 8.1 installed drivers same order. Did the test no shock. Nothing working with checker and hex. When into CMD ran fsutil behavior query DisableDeleteNotify the result was 0 which means windows says trim is enabled. Even went into regedit changed EnablePrefetcher & EnableSuperfetch to 0. Stock install has them with 3. Tested both 0 3 after reboot of editing. Still not working.

    So now I know the raid can trim in Windows 7 I ask myself do I want to be stuck in the past with an good os. Or do I go with what Microsoft is trying to become. I will admit windows 8 did suck But 8.1 is so smooth and quick few kinks in it but nothing a true lover of custom installed windows can’t fix. I almost have it set up to how I like it. Just few tweaks and ill be laughing. I dare to say I love Windows 8.1 and with skydrive (Onedrive) sync reformatting is no long a nightmare.

    I would like to know If I am missing a step. Or if someone with the same corsair drives and z87 drive and windows 8.1 are having the same problems. Or someone with Different brand with the SandForce 2281 controller gets the same problems on install?

    Few people have said to test different drivers. Which I will try Just need to find the easiest way to load an older driver into Windows 8.1 with out formatting. Is it possible?



    I will also be testing the two Force 120 LS once I get my second one free of data that on it.

    Thanks for your time.
     
  2. The SSD Guy

    The SSD Guy Administrator Staff Member

    Messages:
    780
    Likes Received:
    10
    Trophy Points:
    18
    Sorry for the late reply and read this thoroughly. Unfortunately, I have no suggestions on this problem...sorry.
     

Share This Page